Aktualizacja programów z serii CodeTwo Exchange Rules – wsparcie dla OAuth 2.0 i więcej

Jeśli używasz naszego oprogramowania do zarządzania podpisami i notami prawnymi na serwerze Exchange, mamy dobre wieści. Właśnie wydaliśmy nowe wersje poniższych produktów z serii CodeTwo Exchange Rules:

Aktualizacja sprawia, że mechanizm służący do dodawania stopek do Elementów Wysłanych – Sent Items Update (SIU) wykorzystuje teraz protokół OAuth 2.0 aby połączyć się z Microsoft 365 (Office 365). Ponadto wprowadziliśmy zmiany w architekturze powyższych programów i dodaliśmy kilka poprawek eliminujących problemy zgłaszane nam przez klientów. Aktualizacja jest wymagana, jeżeli CodeTwo Exchange Rules (Pro) używany jest w środowisku hybrydowym i opcjonalna (ale rekomendowana), jeżeli program zainstalowany jest na serwerze Exchange, który działa wyłącznie lokalnie.

Aktualizacja Exchange Rules - wsparcie OAuth

Usługa SIU wspiera nową metodę uwierzytelniania – OAuth 2.0

Sent Items Update to usługa, która pozwala użytkownikowi końcowemu zobaczyć w folderze Elementy Wysłane podpisy które nasze oprogramowanie dodaje na poziomie serwera. Usługa działa niezależnie od urządzenia i klienta pocztowego używanego do wysyłania maili. SIU działa również w środowiskach hybrydowych, aktualizując wiadomości wysyłane z Microsoft 365/ Office 365.

Od października 2020, Microsoft zaczął blokować protokół basic authentication w Exchange Online. Wyłączanie tej podstawowej formy uwierzytelniania rozpoczęto od nowych tenantów oraz organizacji, które nie miały zarejestrowanego użycia protokołu basic authentication. Najnowsza aktualizacja naszego oprogramowania pozwala na wykorzystanie bezpieczniejszej metody uwierzytelniania – OAuth 2.0 – dla połączeń z Microsoft 365. Ponadto, administratorzy nie będą już musieli wpisywać danych logowania do Microsoft 365 bezpośrednio w programie. Aby korzystać z usługi w środowiskach hybrydowych, musi być ona zarejestrowana w Azure Active Directory. Rejestracja następuje automatycznie podczas konfiguracji, ale można jej też dokonać ręcznie, w sposób opisany w tym artykule.

Exchange Rules SIU automatyczna rejestracja

Innymi słowy, jeżeli CodeTwo Exchange Rules używany jest w hybrydowym środowisku Exchange, jego aktualizacja do najnowszej wersji jest wymagana. Dzięki temu, użytkownicy mogą mieć pewność, że nasze oprogramowanie nie przestanie działać dla połączeń z chmurą Microsoft 365 po tym, jak protokół basic authentication zostanie wyłączony.

Ważne: Klienci, którzy już korzystali z funkcji Sent Items Update w środowiskach hybrydowych, muszą ponownie skonfigurować usługę po aktualizacji CodeTwo Exchange Rules do wersji x.14 (lub późniejszej). W innym wypadku, użytkownicy końcowi nie będą widzieć swoich podpisów w Elementach Wysłanych. Podczas aktualizacji, program wyświetli komunikat o konieczności zmian w ustawieniach.

Dowiedz się więcej o usłudze SIU i jej konfiguracji w podręczniku użytkownika dla produktu z którego korzystasz:

Skorzystaj z poniższych odnośników jeśli chcesz się dowiedzieć o pozostałych zmianach w najnowszych wersjach programów:

Jak zaktualizować oprogramowanie

W pierwszej kolejności należy pobrać najnowszą wersję aktualnie używanego programu z serii CodeTwo Exchange Rules, korzystając z poniższych linków:

Następnie zainstalować aktualizację na obecnie używanej wersji programu. Wszystkie ustawienia reguł dodających stopki pozostaną bez zmian. Jeśli którykolwiek składnik programu (Usługa Exchange Rules lub Panel Administracyjny) jest zainstalowany na więcej niż jednej maszynie, aktualizację należy zainstalować na każdej z nich.

Ważne: Przed aktualizacją CodeTwo Exchange Rules Pro na serwerze Exchange 2007 lub 2010 przeczytaj tę część bloga.

Aktualizacja jest darmowa dla wszystkich klientów posiadających licencję na tę samą wersję główną programu (pierwsza cyfra obecnie zainstalowanej wersji musi być taka sama jak numer nowo wydanej aktualizacji, czyli na przykład 2.13.0.0).

Jeśli masz starszą wersję programu (np. 1.4.5.) i chcesz dokonać aktualizacji do najnowszej wersji, zacząć korzystać z innego programu CodeTwo lub masz jakiekolwiek inne pytania dotyczące naszego oprogramowania, zachęcamy do kontaktu z nami.

Ważna informacja dla organizacji korzystających z Exchange 2007 lub 2010

CodeTwo Exchange Rules Pro działa na każdej wersji serwera Exchange, począwszy od Exchange 2007. Jednak aby program był w pełni kompatybilny z protokołem uwierzytelniania OAuth 2.0, Panel Administracyjny wymaga do działania .NET Framework w wersji 4.5. Oznacza to, że komponent służący do zarządzania usługą nie może być już zainstalowany bezpośrednio na serwerze Exchange 2007 lub 2010, jako że te wersje serwera Exchange nie wspierają .NET Framework 4.5.

Aktualizacja programu nie jest wymagana, aby móc dalej z niego korzystać w środowisku Exchange 2007 lub 2010. Niemniej jednak w przypadku instalacji najnowszej wersji programu, Panel Administracyjny musi być zainstalowany na maszynie klienckiej, która spełnia określone wymagania systemowe, aby możliwe było zarządzanie regułami email. Nie ma zmian odnośnie usługi Exchange Rules (odpowiedzialnej za przetwarzanie tych reguł). Usługa ta wciąż musi być zainstalowana na serwerze.

Ważne: Po aktualizacji CodeTwo Exchange Rules Pro na serwerze Exchange 2007 lub 2010, Panel Administracyjny zostanie odinstalowany. Po zainstalowaniu Panelu na maszynie klienckiej, wszystkie reguły i ustawienia będą automatycznie zsynchronizowane (w przypadku korzystania z funkcjonalności Access Rights, należy się upewnić, że co najmniej jeden użytkownik będzie miał dostęp do panelu oraz reguł email z nowej maszyny). Jeśli jednak w bibliotece szablonów podpisów były zapisane niestandardowe szablony, trzeba je przenieść ręcznie na nową maszynę. Ten artykuł pokazuje jak to zrobić.

Dodaj komentarz

Twój adres e-mail nie zostanie opublikowany.

You may use these HTML tags and attributes: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong>

*

*